Thread: May I please have help with logging in?

Results 1 to 7 of 7
  1. #1 May I please have help with logging in? 
    Registered Member

    Join Date
    May 2015
    Posts
    127
    Thanks given
    73
    Thanks received
    32
    Rep Power
    82
    Hi there. I have a 414 client & update server that works. The update server will get the client to load to the login screen, but logging in will get 'error connecting to server.'

    Here are some files that I uploaded for reference to: [Only registered and activated users can see links. ]

    I've tried the login-server included in that download, but changing to the correct port & the settings.ini, the client doesn't seem to log in.


    I'd really would just like a blank server to log into. However if someone can get the Hyperion 464 or Apollo 484 sources in the above download to log in, that'd be great. ( Or if anyone has an existing source of any kind for this revision. )
    The 484 Apollo was converted to 414 before by a user named 'Snake', & there was at one time a Hyperion done too, so that's why those sources are there in-case they can help getting everything working.

    Thank you very much for your time & I hope that you can help me! =)
    - Snow.
    Reply With Quote  
     

  2. #2  
    RuneTimes

    RainDropzZ's Avatar
    Join Date
    Oct 2010
    Posts
    348
    Thanks given
    28
    Thanks received
    93
    Discord
    View profile
    Rep Power
    471
    Do you host the server localy? If yes, did you change the ip in the client to 127.0.0.1(loopback adress)?
    If you are hosting it on a VPS did you portforward on the VPS and change the ip in the client to the ip of the VPS?
    Reply With Quote  
     

  3. #3  
    Registered Member

    Join Date
    May 2015
    Posts
    127
    Thanks given
    73
    Thanks received
    32
    Rep Power
    82
    Quote Originally Posted by RainDropzZ View Post
    Do you host the server localy? If yes, did you change the ip in the client to 127.0.0.1(loopback adress)?
    If you are hosting it on a VPS did you portforward on the VPS and change the ip in the client to the ip of the VPS?
    Yup, it's locally. Here's the snippets in Client & GameScreen.java ( unsure what to change, changed some things but it was a no go ):

    Code:
     final boolean validHost() {
    		String host = getDocumentBase().getHost().toLowerCase();
    		if (host.endsWith("jagex.com"))
    		    return true;
    		if (host.endsWith("runescape.com"))
    		    return true;
    		if (host.endsWith("127.0.0.1"))
    		    return true;
    		for (/**/;
    		     (host.length() > 0 && host.charAt(host.length() - 1) >= '0'
    		      && host.charAt(host.length() - 1) <= '9');
    		     host = host.substring(0, host.length() - 1)) {
    		    /* empty */
    		}
    		if (host.endsWith("192.168.1."))
    		    return true;
    		error("invalidhost");
    		return false;
        }

    Along with this in Client.java:

    Code:
    	/**
    			 * Set ip
    			 */
    			if (packetOpcode == 114) {
    			    int ip = Client.inputStream.getInt();
    			    dnsNode = Client.signlink.method761(ip);
    			    packetOpcode = -1;
    			    return true;
    			}
    Code:
    			Client.errorExit();
       			if (param[4].equals("free"))
       				Client.allowMemberItems = false;
       			else if (param[4].equals("members"))
       				Client.allowMemberItems = true;
       			else
       				Client.errorExit();
       			Client instance = new Client();
       			instance.init(InetAddress.getLocalHost(), "runescape", 765, 503, 414, 12, Client.modeWhat + 32);
       			Client.clientFrame.setLocation(40, 40);
        	} catch (Exception exception) {
        		Client.throwError(exception, null);
        	}
        }

    Thank you ^_^
    Reply With Quote  
     

  4. #4  
    It's time for change.
    Blazedroid's Avatar
    Join Date
    Jul 2019
    Posts
    43
    Thanks given
    0
    Thanks received
    1
    Discord
    View profile
    Rep Power
    11
    You need to look for the clients config file that defines which host to connect to. What you posted isn't what you need.
    [Only registered and activated users can see links. ]
    Reply With Quote  
     

  5. #5  
    Registered Member

    Join Date
    Feb 2010
    Posts
    3,191
    Thanks given
    1,124
    Thanks received
    840
    Discord
    View profile
    Rep Power
    1525
    U using displees 414? I packaged and refactored that with gradle integration, going to work on a 414 server when I got time.

    Did u debug the login to make sure the connection is established?
    Reply With Quote  
     

  6. #6  
    Registered Member

    Join Date
    May 2015
    Posts
    127
    Thanks given
    73
    Thanks received
    32
    Rep Power
    82
    Quote Originally Posted by Fire Cape View Post
    U using displees 414? I packaged and refactored that with gradle integration, going to work on a 414 server when I got time.

    Did u debug the login to make sure the connection is established?
    I'm using a client that I found & then later gave to displee to see if I could use his interface tool for it. The cache is from displee though.

    I did a debug run in intellij & it said that the VM was using a higher port number on the login server?

    I do notice a hang on the client when I attempt to login with the login server enabled, vs without the login server.

    I currently don't have a server for 414 other than the update & the login server that I provided. I read that the Apollo 484 should support 414

    Quote Originally Posted by Blazedroid View Post
    You need to look for the clients config file that defines which host to connect to. What you posted isn't what you need.
    I'm not sure where the config file would be, but I'll give another look.

    Thank you for the help so far to both of you guys. =)
    Reply With Quote  
     

  7. #7  
    Registered Member

    Join Date
    Feb 2010
    Posts
    3,191
    Thanks given
    1,124
    Thanks received
    840
    Discord
    View profile
    Rep Power
    1525
    Quote Originally Posted by SnowEssence View Post
    I'm using a client that I found & then later gave to displee to see if I could use his interface tool for it. The cache is from displee though.

    I did a debug run in intellij & it said that the VM was using a higher port number on the login server?

    I do notice a hang on the client when I attempt to login with the login server enabled, vs without the login server.

    I currently don't have a server for 414 other than the update & the login server that I provided. I read that the Apollo 484 should support 414



    I'm not sure where the config file would be, but I'll give another look.

    Thank you for the help so far to both of you guys. =)
    The hang suggests it is attempting to connect at least

    Two things I can think of just taking a little look at what I've seen so far. The port number the server connects to can vary depending on if the client is run as local or live it's either world id + 40000 or 43594 iirc

    Second you might just need to edit the packets block to accommodate version differences. I'm not that familiar with Apollo but the packets will most likely be different (the numbers certainly will) but I know Apollo does have multi revision support so idk.
    Reply With Quote  
     


Thread Information
Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)


User Tag List

Similar Threads

  1. help with log in
    By leeg146xx in forum Help
    Replies: 1
    Last Post: 04-29-2018, 10:03 PM
  2. Help please trying to change log in box
    By garrydowling2011 in forum Help
    Replies: 0
    Last Post: 02-28-2012, 07:56 PM
  3. Help with logging in.
    By Bucky in forum Help
    Replies: 0
    Last Post: 09-30-2009, 03:00 AM
  4. Help 508 log in screen
    By Gryffindor in forum Help
    Replies: 8
    Last Post: 02-22-2009, 07:11 AM
  5. help with freezes in server
    By anc13nts in forum Help
    Replies: 3
    Last Post: 08-05-2008, 09:42 AM
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •