Thread: Eclipse error, can't figure out?

Results 1 to 6 of 6
  1. #1 Eclipse error, can't figure out? 
    Registered Member
    Join Date
    Jul 2019
    Posts
    1
    Thanks given
    0
    Thanks received
    0
    Rep Power
    0
    super noob question can't figure out why eclipse keeps giving me this error. why would it tell me the main class can't be found, it is exactly where

    [Only registered and activated users can see links. ]

    sorry for edits, forgot how to img tag.
    Reply With Quote  
     

  2. #2  
    Registered Member
    arch337's Avatar
    Join Date
    Sep 2008
    Posts
    2,712
    Thanks given
    170
    Thanks received
    285
    Discord
    Arch337#1337
    Rep Power
    631
    There is no main function inside your file that you are trying to run. You'll need to configurate your run and find the file in which have your main function.


    "A fail act is something you do regular, but a dumb act is something you can learn from"
    Spoiler for Problem?:
    Reply With Quote  
     

  3. #3  
    Registered Member Kharyrll.'s Avatar
    Join Date
    Feb 2018
    Posts
    227
    Thanks given
    1
    Thanks received
    20
    Rep Power
    42
    You may be trying to load the wrong server/client aswell.
    Reply With Quote  
     

  4. #4  
    OWNER @ BOFA (Now Hiring)
    Mr Bill's Avatar
    Join Date
    May 2010
    Posts
    518
    Thanks given
    15
    Thanks received
    31
    Discord
    Bill#0311
    Rep Power
    37
    The actual problem is probably how you imported your project into Eclipse. Make sure you import your server and client separately, don't import the folder that contains your source/client.

    Just for testing purposes, create a batch file inside of the server folder. Put this in there:

    @echo off
    title Elvarg
    "C:\Program Files (x86)\Java\jdk-12.0.2\bin\java.exe" -server -Xmx1024m -cp bin;lib/* com.elvarg.Server
    pause
    Change the JDK to your version.
    Reply With Quote  
     

  5. #5  
    Registered Member Kharyrll.'s Avatar
    Join Date
    Feb 2018
    Posts
    227
    Thanks given
    1
    Thanks received
    20
    Rep Power
    42
    Quote Originally Posted by Mr Bill View Post
    The actual problem is probably how you imported your project into Eclipse. Make sure you import your server and client separately, don't import the folder that contains your source/client.

    Just for testing purposes, create a batch file inside of the server folder. Put this in there:



    Change the JDK to your version.
    He shouldn't need to change JDK inside Eclipse should he? I'd about bet he's trying to import them both as one file like you said.

    Import the server, client as separate folders if you're using them as one folder on your desktop just split them up.
    Reply With Quote  
     

  6. #6  
    Registered Member
    Join Date
    Jun 2013
    Posts
    425
    Thanks given
    77
    Thanks received
    35
    Rep Power
    50
    Add me on discord and just PM me with this thread link(got my settings off)


    Ab#3264
    Reply With Quote  
     


Thread Information
Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)


User Tag List

Similar Threads

  1. T2 error... Can't figure it out.
    By Gallus in forum Help
    Replies: 2
    Last Post: 01-17-2015, 03:34 AM
  2. Can't figure out this Eclipse error.
    By snaper in forum Help
    Replies: 3
    Last Post: 08-03-2013, 12:26 PM
  3. Replies: 1
    Last Post: 11-21-2011, 04:39 AM
  4. Error problem can't figure out :S
    By ibaw in forum Help
    Replies: 4
    Last Post: 08-22-2010, 05:55 PM
  5. Can't figure out these errors, tried alot
    By Owner trint in forum Help
    Replies: 10
    Last Post: 01-05-2009, 09:25 PM
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •