Thread: JNI Error, help please!

Results 1 to 4 of 4
  1. #1 JNI Error, help please! 
    Registered Member
    Join Date
    Jun 2019
    Posts
    3
    Thanks given
    0
    Thanks received
    0
    Rep Power
    0
    Hello, I am noob to this stuff but i would love if anyone could help me.
    When i run my source i get this error:

    Error: A JNI error has occurred, please check your installation and try again
    Exception in thread "main" java.lang.UnsupportedClassVersionError: server/Server has been compiled by a more recent version of the Java Runtime (class file version 56.0), this version of the Java Runtime only recognizes class file versions up to 52.0
    at java.lang.ClassLoader.defineClass1(Native Method)
    at java.lang.ClassLoader.defineClass(Unknown Source)
    at java.security.SecureClassLoader.defineClass(Unknow n Source)
    at java.net.URLClassLoader.defineClass(Unknown Source)
    at java.net.URLClassLoader.access$100(Unknown Source)
    at java.net.URLClassLoader$1.run(Unknown Source)
    at java.net.URLClassLoader$1.run(Unknown Source)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at sun.launcher.LauncherHelper.checkAndLoadMain(Unkno wn Source)
    Press any key to continue . . .
    I don't really get it, i've tried everything changing locations moving...Help me out.
    Reply With Quote  
     

  2. #2  
    Registered Member

    Join Date
    Oct 2016
    Posts
    132
    Thanks given
    70
    Thanks received
    37
    Rep Power
    105
    Error: A JNI error has occurred, please check your installation and try again
    Exception in thread "main" java.lang.UnsupportedClassVersionError: server/Server has been compiled by a more recent version of the Java Runtime (class file version 56.0), this version of the Java Runtime only recognizes class file versions up to 52.0

    Try updating your java?
    Reply With Quote  
     

  3. #3  
    Registered Member
    arch337's Avatar
    Join Date
    Sep 2008
    Posts
    2,705
    Thanks given
    170
    Thanks received
    285
    Discord
    Arch337#1337
    Rep Power
    606
    Either compile it in a different jdk or use a different jre version as the one you are trying to use is a lower version (hence the message).


    "A fail act is something you do regular, but a dumb act is something you can learn from"
    Spoiler for Problem?:
    Reply With Quote  
     

  4. #4  
    Open For Services

    Join Date
    Jun 2019
    Posts
    72
    Thanks given
    3
    Thanks received
    16
    Discord
    Aaron.#0429
    Rep Power
    43
    Yeah i would try to use your own java version.
    Reply With Quote  
     


Thread Information
Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)


User Tag List

Similar Threads

  1. Error help please
    By Balmora in forum Help
    Replies: 3
    Last Post: 04-12-2009, 09:55 PM
  2. Client error help please :)
    By junior rider in forum Help
    Replies: 2
    Last Post: 03-14-2009, 05:59 AM
  3. 508 webclient error, help please!
    By arman in forum Help
    Replies: 3
    Last Post: 03-04-2009, 05:57 AM
  4. 2 errors?.. help please.
    By blacksh00t in forum Help
    Replies: 9
    Last Post: 02-22-2009, 08:24 PM
  5. Err! error.. help please?
    By Ryan™ in forum Help
    Replies: 6
    Last Post: 02-05-2009, 12:22 AM
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •