Thread: I can't wear an item (not an custom item)

Results 1 to 7 of 7
  1. #1 I can't wear an item (not an custom item) 
    Registered Member
    Join Date
    Apr 2019
    Posts
    16
    Thanks given
    0
    Thanks received
    0
    Rep Power
    11
    Hello guys , In every time i trying to wear a berserker ring (i) I'm facing a problem , i can't wear it (it stands on the inv) and an error appears on the (run.bat)
    [Only registered and activated users can see links. ]
    I've tried to add it on the item.java in rings section , but the nothing happened!
    please someone help me , what could i do..
    The original berserker ring is working and i can wear it!
    thanks
    Reply With Quote  
     

  2. #2  
    Be the change you wanna see!

    Nozemi's Avatar
    Join Date
    Jul 2010
    Posts
    309
    Thanks given
    88
    Thanks received
    96
    Discord
    Nozemi#0001
    Rep Power
    340
    Quote Originally Posted by abusuhaib View Post
    Hello guys , In every time i trying to wear a berserker ring (i) I'm facing a problem , i can't wear it (it stands on the inv) and an error appears on the (run.bat)
    [Only registered and activated users can see links. ]
    I've tried to add it on the item.java in rings section , but the nothing happened!
    please someone help me , what could i do..
    The original berserker ring is working and i can wear it!
    thanks
    Are you not using an IDE? Get yourself the community edition of IntelliJ. Should be easier.

    You have an ArrayIndexOutOfBounds error in the ItemAssistant.java it seems.

    [Only registered and activated users can see links. ]
    If you don't know what ArrayIndexOutOfBounds means.

    The error you got, tells you which file and line of that file the error occurred on.
    [Only registered and activated users can see links. ]
    Reply With Quote  
     

  3. #3  
    Registered Member
    Join Date
    Apr 2019
    Posts
    16
    Thanks given
    0
    Thanks received
    0
    Rep Power
    11
    xDD it's okay I'll code using the notepad++ .
    Could you help me solving this issue , it seems like a hard problem :/
    Thanks BTW
    Reply With Quote  
     

  4. #4  
    Registered Member
    arch337's Avatar
    Join Date
    Sep 2008
    Posts
    2,712
    Thanks given
    170
    Thanks received
    285
    Discord
    Arch337#1337
    Rep Power
    631
    I suggest a ide rather then notepad++.
    The error tells you ItemAssistant.java at line 1248 is where your error started to occur.


    "A fail act is something you do regular, but a dumb act is something you can learn from"
    Spoiler for Problem?:
    Reply With Quote  
     

  5. #5  
    Be the change you wanna see!

    Nozemi's Avatar
    Join Date
    Jul 2010
    Posts
    309
    Thanks given
    88
    Thanks received
    96
    Discord
    Nozemi#0001
    Rep Power
    340
    Quote Originally Posted by abusuhaib View Post
    xDD it's okay I'll code using the notepad++ .
    Could you help me solving this issue , it seems like a hard problem :/
    Thanks BTW
    No, it absolutely isn't okay to write Java in Notepad++. Eclipse or IntelliJ will help you a lot.
    It really is a simple problem, and working with Eclipse or IntelliJ might help you solve the issue,
    and similar issues in the future.
    [Only registered and activated users can see links. ]
    Reply With Quote  
     

  6. #6  
    Registered Member
    Join Date
    Apr 2019
    Posts
    16
    Thanks given
    0
    Thanks received
    0
    Rep Power
    11
    Okay guys thanks so much, ill download this intelliJ now..
    Reply With Quote  
     

  7. #7  
    Be the change you wanna see!

    Nozemi's Avatar
    Join Date
    Jul 2010
    Posts
    309
    Thanks given
    88
    Thanks received
    96
    Discord
    Nozemi#0001
    Rep Power
    340
    Quote Originally Posted by abusuhaib View Post
    Okay guys thanks so much, ill download this intelliJ now..
    I've been where you are now. Most of us have tbh. It really is going to help a lot to use an IDE.
    You no longer need to use compile.bat or run.bat either.
    [Only registered and activated users can see links. ]
    Reply With Quote  
     


Thread Information
Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)


User Tag List

Similar Threads

  1. Replies: 4
    Last Post: 12-01-2015, 05:59 AM
  2. Replies: 1
    Last Post: 06-29-2013, 07:12 PM
  3. Replies: 0
    Last Post: 06-29-2013, 05:59 PM
  4. Custom items not equipable?
    By Salty in forum Help
    Replies: 16
    Last Post: 02-05-2010, 06:37 AM
  5. Anyone have an item editer? (for custom items)
    By araf5 in forum RS2 Client
    Replies: 2
    Last Post: 06-12-2008, 08:18 PM
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •