Thread: running source on eclipse problem

Page 1 of 2 12 LastLast
Results 1 to 10 of 12
  1. #1 running source on eclipse problem 
    Registered Member
    Join Date
    Feb 2019
    Posts
    4
    Thanks given
    0
    Thanks received
    0
    Rep Power
    0
    Hello everyone, i am Santorie and i am a fairly new developer.
    I am working on a project of mine and bumped into a problem,
    i managed to run the server, was editing shops, point systems, when i rerun the server this happens:
    [Only registered and activated users can see links. ]
    it loads and stops there, doesnt continue.
    The server was ussualy running in 10-14 seconds
    now its been loading for 15 minutes and still not done.
    Can anyone give me an explanation why this is happening?
    Reply With Quote  
     

  2. #2  
    Registered Member
    arch337's Avatar
    Join Date
    Sep 2008
    Posts
    2,705
    Thanks given
    170
    Thanks received
    285
    Discord
    Arch337#1337
    Rep Power
    606
    Check your main function and locate where exactly it stops.


    "A fail act is something you do regular, but a dumb act is something you can learn from"
    Spoiler for Problem?:
    Reply With Quote  
     

  3. #3  
    Registered Thanker
    MrClassic's Avatar
    Join Date
    Oct 2008
    Age
    24
    Posts
    1,857
    Thanks given
    14,092
    Thanks received
    292
    Rep Power
    5000
    Maybe you did something wrong while editing shops? It could be from missing syntaxes to missing a space
    Thanks, MrClassic.

    [Only registered and activated users can see links. ]

    [Only registered and activated users can see links. ]
    Reply With Quote  
     

  4. #4  
    Be the change you wanna see!

    Nozemi's Avatar
    Join Date
    Jul 2010
    Posts
    286
    Thanks given
    79
    Thanks received
    84
    Discord
    Nozemi#0001
    Rep Power
    173
    A good way to figure out issues like these, would be to run the server in debug mode and set breakpoints to debug the loading process.

    However, you know about when it stops loading, which is where you'd start debugging.
    Reply With Quote  
     

  5. #5  
    Registered Member
    Join Date
    Feb 2019
    Posts
    4
    Thanks given
    0
    Thanks received
    0
    Rep Power
    0
    Quote Originally Posted by MrClassic View Post
    Maybe you did something wrong while editing shops? It could be from missing syntaxes to missing a space
    wouldnt it then show an error or something in eclipse?
    Reply With Quote  
     

  6. #6  
    Be the change you wanna see!

    Nozemi's Avatar
    Join Date
    Jul 2010
    Posts
    286
    Thanks given
    79
    Thanks received
    84
    Discord
    Nozemi#0001
    Rep Power
    173
    Quote Originally Posted by santorie View Post
    wouldnt it then show an error or something in eclipse?
    Not unless you hardcode those shops, or edit code that handles shops.
    Reply With Quote  
     

  7. #7  
    Website Developer

    ruby.exe's Avatar
    Join Date
    Mar 2018
    Posts
    101
    Thanks given
    1,000
    Thanks received
    199
    Discord
    Ruby#3962
    Rep Power
    401
    honestly looks like missing syntax to me and it's easy to make those mistakes. breakpoints will come in handy

    [Only registered and activated users can see links. ]

    Syntax is easy. Math is hard.
    Reply With Quote  
     

  8. #8  
    Banned

    Join Date
    Nov 2017
    Posts
    46
    Thanks given
    46
    Thanks received
    44
    Rep Power
    0
    Try replacing your shops with a backup shops file and see if the problem persists.
    Reply With Quote  
     

  9. #9  
    Registered Member
    Join Date
    Feb 2019
    Posts
    4
    Thanks given
    0
    Thanks received
    0
    Rep Power
    0
    So everyone, fixed the problem... Like Sapphira said a syntax was missing, didnt check good... thanks
    Now i actually have another question, ive been searching for the shops to reedit, i only found custom shops (pvm pts, boss pts, trivia pts, ach pts,...) but i cant seem to find the normal shops (magic, range, armour, weapon, general,...) i searched up some guides on youtube but i cant seem to find the file that is shown on the guide.


    I am also looking for a developer who could help me out sometimes, not full time. Leave your discord if interested.
    Reply With Quote  
     

  10. #10  
    Enum_ Services
    Enum_'s Avatar
    Join Date
    May 2016
    Posts
    112
    Thanks given
    5
    Thanks received
    26
    Rep Power
    33
    Quote Originally Posted by santorie View Post
    So everyone, fixed the problem... Like Sapphira said a syntax was missing, didnt check good... thanks
    Now i actually have another question, ive been searching for the shops to reedit, i only found custom shops (pvm pts, boss pts, trivia pts, ach pts,...) but i cant seem to find the normal shops (magic, range, armour, weapon, general,...) i searched up some guides on youtube but i cant seem to find the file that is shown on the guide.


    I am also looking for a developer who could help me out sometimes, not full time. Leave your discord if interested.
    I don’t know what server your using so it’s kinda hard to help with this. I know on some servers they have those shops in shops.cfg, but on others you just create a new shop in the customs shop with your range, magic, and melee items, and make that npc open that shop.
    Reply With Quote  
     

Page 1 of 2 12 LastLast

Thread Information
Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)


User Tag List

Similar Threads

  1. Replies: 4
    Last Post: 06-06-2014, 05:02 AM
  2. How do i run client on eclipse
    By obeyscape in forum Help
    Replies: 4
    Last Post: 04-20-2014, 06:39 AM
  3. Run error on eclipse!
    By scarlet nite in forum Help
    Replies: 3
    Last Post: 07-22-2013, 09:38 PM
  4. 718 running source with Eclipse error
    By daggertail90 in forum Help
    Replies: 3
    Last Post: 04-07-2013, 05:39 PM
  5. Running Server on MAC Problem
    By Dagger in forum Help
    Replies: 2
    Last Post: 07-25-2012, 07:27 PM
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •