Thread: 667 Server will only connect to client when on localhost

Results 1 to 4 of 4
  1. #1 667 Server will only connect to client when on localhost 
    Registered Member
    Join Date
    Dec 2011
    Posts
    12
    Thanks given
    0
    Thanks received
    0
    Rep Power
    11
    Hey guys. I'm using the HumidityX 667 source. I've tried connecting on my IP through both the ZenithScape and the default Humidity clients, yet nothing works.

    - My port is forwarded properly, and yes I checked on 2 different port sniffers
    - Client's Loader.java was changed to match my IP instead of localhost - when on localhost it connects fine, when on my IP it doesn't
    - Everything was compiled properly, like I said it works fine on localhost

    This is where both clients hang:



    Port is properly forwarded:





    Any help is appreciated
    Reply With Quote  
     

  2. #2  
    Road to max

    Join Date
    Mar 2011
    Posts
    448
    Thanks given
    102
    Thanks received
    44
    Rep Power
    10
    Just connect using local host...? Only other people need to use your ip to connect.
    Reply With Quote  
     

  3. #3  
    Registered Member
    Join Date
    May 2014
    Posts
    85
    Thanks given
    30
    Thanks received
    14
    Rep Power
    20
    If you are trying to connect from the same computer that the server is hosted on, you are not allowed to use your IP address to connect. From what I see, a lot of people use No-IP, which routes to your IP. Using No-IP will cause the same problems. Either use your IPv4 address, "localhost", or "127.0.0.1". This is called performing a loop-back. - "NAT loopback is especially useful when the server hosts a domain name that resolves to a public address. When the router does not perform NAT loopback, any connection attempts to that IP address fail."

    You can read more about NAT loop-backs here: [Only registered and activated users can see links. ]
    Reply With Quote  
     

  4. #4  
    Registered Member
    Join Date
    Dec 2011
    Posts
    12
    Thanks given
    0
    Thanks received
    0
    Rep Power
    11
    Thanks guys, but my two other admins who live in the US also can't connect when my server is up on the port I forwarded. Same thing happens with the client, even though the client is set to use that same port and my IP. Any ideas?
    Reply With Quote  
     


Thread Information
Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)


User Tag List

Similar Threads

  1. server won't connect to client
    By rkcjeffrey in forum Help
    Replies: 3
    Last Post: 04-04-2012, 12:42 AM
  2. Replies: 18
    Last Post: 08-22-2010, 10:26 PM
  3. Replies: 3
    Last Post: 08-13-2009, 05:33 AM
  4. Replies: 18
    Last Post: 04-24-2008, 06:39 PM
  5. Replies: 10
    Last Post: 02-22-2008, 11:17 PM
Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •