Thread: PI npc drop error at run

Results 1 to 5 of 5
  1. #1 PI npc drop error at run 
    Registered Member
    Join Date
    Mar 2011
    Posts
    26
    Thanks given
    0
    Thanks received
    2
    Rep Power
    1
    well, i add the drops to npcdrops.TSM , but when i run the server it gives me an error. this is the error:

    java.util.nosuchelementexception: no line found
    at java.util.scanner.nextline
    at server.models.npcs.NPCDROPS.loaddrops(npcdrops.jav a:37)
    at server.models.npcs.NPCDROPS(init)npcdrops.java.15)

    this is the code i am trying to use:

    #Giant rat
    86:1 995:1000 554:100

    any help? i am just wondering why im getting that error, i have been searching for about a day for an answer.
    Reply With Quote  
     

  2. #2  
    Registered Member
    Join Date
    Feb 2011
    Posts
    359
    Thanks given
    10
    Thanks received
    9
    Rep Power
    10
    Are you spacing it or Tabbing it.
    So it would look like.

    86:1 (TAB) 995:1000 or are you doing 86:1 (Space) 995:1000
    ?
    Reply With Quote  
     

  3. #3  
    Registered Member
    Join Date
    Mar 2011
    Posts
    26
    Thanks given
    0
    Thanks received
    2
    Rep Power
    1
    yes, i am tabbing it. any ideas?
    Reply With Quote  
     

  4. #4  
    Registered Member
    Join Date
    Feb 2011
    Posts
    359
    Thanks given
    10
    Thanks received
    9
    Rep Power
    10
    Then i'm not sure, i'm having problems myself trying to make NPC's drop items but no one will help me. Good luck on finding your issue and I hope someone can fix it for you
    Reply With Quote  
     

  5. #5  
    Registered Member
    Join Date
    May 2011
    Posts
    104
    Thanks given
    16
    Thanks received
    1
    Rep Power
    1
    #Giant rat
    86:1[TAB]995:1000[TAB]554:100

    If you do it like that it will work fine.
    Reply With Quote  
     


Thread Information
Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 15
    Last Post: 08-23-2016, 06:43 PM
  2. Run error after adding npc's.
    By wooty in forum Help
    Replies: 1
    Last Post: 04-14-2012, 01:46 AM
  3. Weird NPC Drop error (Repping.)
    By savior I in forum Help
    Replies: 4
    Last Post: 08-15-2010, 07:19 AM
  4. Npc Run Error?
    By xSelseor in forum Help
    Replies: 1
    Last Post: 07-10-2010, 12:54 AM
  5. Help please npc drop error
    By Onehiths in forum Help
    Replies: 2
    Last Post: 07-26-2009, 05:48 PM
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •