Thread: Model Appearance off

Results 1 to 2 of 2
  1. #1 Model Appearance off 
    Registered Member
    Join Date
    Dec 2018
    Posts
    15
    Thanks given
    0
    Thanks received
    0
    Rep Power
    11
    So I packed all osrs pvp models into the client and most of them work except Vesta chainbody and morrigans body. I believe i have the itemDef added correctly for both and I tried packing 2 different models for each item and it still shows this.



    I'm not sure if its and issue with the models themselves or my ItemDef for them. Here are my ItemDef

    Code:
    		case 22616:
    			itemDef.name = "Vesta's Chainbody";
    			itemDef.inventoryOptions = new String[5];
    			itemDef.inventoryOptions[1] = "Wear";
    			itemDef.modelId = 35987;
    			itemDef.modelZoom = 1221;//1221
    			itemDef.modelRotation1 = 498;//498
    			itemDef.modelRotation2 = 0;//0
    			itemDef.maleModel = 35953;
    			itemDef.certID = 22616;
    			itemDef.femaleModel = 35965;
    			itemDef.modelOffset2 = 5;//-1
    			itemDef.modelOffset1 = 4;//4
    			itemDef.anInt204 = 0;
    			//itemDef.anInt164 = 42624;
    			//itemDef.anInt197 = 42644;
    		itemDef.description = "An ancient chainbody once worn by Vesta.";
    		break;
    
    case 22641:
    			itemDef.name = "Morrigan's body";
    			itemDef.inventoryOptions = new String[5];
    			itemDef.inventoryOptions[1] = "Wear";
    			itemDef.modelId = 35985;
    			itemDef.modelZoom = 1312;
    			itemDef.maleModel = 35954;
    			itemDef.femaleModel = 35963;
    			itemDef.modelRotation1 = 548;
    			itemDef.modelRotation2 = 2;
    			itemDef.modelOffset2 = 1;
    			itemDef.modelOffset1 = 0;
    			itemDef.anInt204 = 0;
    			//itemDef.anInt165 = 42626;
    			//itemDef.anInt200 = 42643;
    			break;
    Let me know what you think, thanks!
    Reply With Quote  
     

  2. #2  
    Registered Member Vito the Don's Avatar
    Join Date
    Feb 2019
    Age
    21
    Posts
    78
    Thanks given
    6
    Thanks received
    3
    Rep Power
    62
    Your image doesn't work anymore so idk for sure but if you are missing arms or missing torso and just have arms then you need to set the maleEquip2 and femaleEquip2 as well, shown in this thread for ancestral robes:
    [Only registered and activated users can see links. ]
    Gl
    The Dons
    Reply With Quote  
     


Thread Information
Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Zombie Survival - Zombie models [Show off]
    By Dust R I P in forum Models
    Replies: 57
    Last Post: 12-01-2009, 12:54 PM
  2. Replies: 1
    Last Post: 07-21-2009, 12:26 AM
  3. Replies: 0
    Last Post: 07-20-2009, 10:57 PM
  4. Male emo model [show off]
    By Dragonking in forum Models
    Replies: 18
    Last Post: 12-04-2008, 11:33 PM
  5. Some AWSOME models hot off the cache!
    By Colby in forum Models
    Replies: 7
    Last Post: 12-02-2008, 01:32 PM
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •