Thread: [MX3] Client Crashing Upon Item Function

Results 1 to 4 of 4
  1. #1 [MX3] Client Crashing Upon Item Function 
    Registered Member
    Join Date
    Jan 2017
    Posts
    87
    Thanks given
    17
    Thanks received
    7
    Rep Power
    12
    I implemented a book in-game, I went to test it, and my client crashed. It doesn't give a error.

    I shortened the code to be very basic and just open the interface with a test dialogue, and again it crashed. Anyone have any idea why?

    Code:
                    else if (itemId == 600) {
    			player.getInterfaceManager().sendInterface(960);
    			player.getPackets().sendIComponentText(960, 42, "Test");
    			return;
    		}
    Spoiler for Pax is shit:


    Reply With Quote  
     

  2. #2  
    Registered Member
    Bracket's Avatar
    Join Date
    Aug 2009
    Posts
    5,089
    Thanks given
    911
    Thanks received
    1,017
    Rep Power
    1847
    Its probably the interface itself which causes it to crash
    Are you tired of seeing the same thing over and over?
    check out [Only registered and activated users can see links. ]
    Reply With Quote  
     

  3. #3  
    Registered Member

    Join Date
    Nov 2015
    Posts
    725
    Thanks given
    108
    Thanks received
    277
    Rep Power
    1440
    component 42 for that interface probably doesn't exist.
    [Only registered and activated users can see links. ]
    [Only registered and activated users can see links. ]
    Reply With Quote  
     

  4. #4  
    Registered Member
    Join Date
    Jan 2017
    Posts
    87
    Thanks given
    17
    Thanks received
    7
    Rep Power
    12
    Quote Originally Posted by Bracket View Post
    Its probably the interface itself which causes it to crash
    Thanks for the feedback. I tried using a different interface and had the same result.
    I did end up fixing this though.

    Quote Originally Posted by Tommeh View Post
    component 42 for that interface probably doesn't exist.
    Component 42 does exist, I swapped the method I was using to; sendCentralInterface
    It resolved the issue.
    Spoiler for Pax is shit:


    Reply With Quote  
     


Thread Information
Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Client crash upon login.
    By You Only Live Once in forum Help
    Replies: 0
    Last Post: 07-16-2014, 01:11 AM
  2. 718 Client Crash upon Login
    By Methamphetamin in forum Help
    Replies: 0
    Last Post: 05-04-2014, 08:01 PM
  3. Client crash upon opening skillcape shop!
    By EmgScape in forum Help
    Replies: 7
    Last Post: 08-04-2012, 04:52 AM
  4. Client crash upon logging in.
    By johnny2shoe in forum Help
    Replies: 1
    Last Post: 11-26-2009, 05:05 PM
  5. Replies: 6
    Last Post: 07-31-2009, 03:50 AM
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •