Thread: Asus maximus apex ix - no display and no power

Results 1 to 3 of 3
  1. #1 Asus maximus apex ix - no display and no power 
    Enum_ Services
    Enum_'s Avatar
    Join Date
    May 2016
    Posts
    109
    Thanks given
    5
    Thanks received
    26
    Rep Power
    33
    Hi folks,
    I currently just got done building my pc and got windows and everything installed. I turned it off after windows was installed and it sat there unplugged for 3 days. I decided to turn it on and no display is showing. I tried switching from display to hdmi (BTW I am using on board graphics) and It didn't work. I tried getting a gpu and still nothing. I decided to take out the ram the battery, the cpu and re-seated them. After about 6 hours of trying to fix it I decided to put all my parts in pcpartpicker to see if there were issues and sure enough it says "1 additional eps connector is required."
    I recently got another eps connector for my motherboard because I believed my motherboard was not receiving enough power to power the cpu. I plugged the connector in and click the power button and nothing happens. Its like the power supply isn't even plugged in. The motherboards lights are on but the led screen is not because the pc can't even turn on at this point. Any help would be appreciated.

    Thanks!

    MOTHERBOARD - ASUS MAXIMUS IX APEX
    CPU - I7-7700k
    Ram - RIPJAWS DDR4 3200mhz
    PSU - CORSAIR CX650M
    Last edited by Enum_; 03-24-2019 at 06:26 AM.
    Reply With Quote  
     

  2. #2  
    Registered Member
    Stimulant's Avatar
    Join Date
    Jan 2013
    Age
    24
    Posts
    1,434
    Thanks given
    228
    Thanks received
    178
    Rep Power
    568
    Might not be the PSU, I've read it's 650W which should be enough.
    Reply With Quote  
     

  3. #3  
    Enum_ Services
    Enum_'s Avatar
    Join Date
    May 2016
    Posts
    109
    Thanks given
    5
    Thanks received
    26
    Rep Power
    33
    Issue resolved. It ended up being the motherboard and Asus replaced it.
    Last edited by Enum_; 03-24-2019 at 06:25 AM.
    Reply With Quote  
     


Thread Information
Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)


User Tag List

Similar Threads

  1. Replies: 3
    Last Post: 04-25-2009, 03:38 PM
  2. Replies: 0
    Last Post: 04-10-2009, 03:57 PM
  3. PK KingDom No-Ip and Hamachi + Our Own Forum
    By KingDom-Scape in forum RS2 Server
    Replies: 6
    Last Post: 07-02-2008, 02:11 AM
  4. No-ip and Portforwarding guide.
    By s0cc3r in forum Tutorials
    Replies: 4
    Last Post: 08-20-2007, 06:51 AM
  5. ban no clippers and clientdrop
    By o0pku1 in forum Tutorials
    Replies: 5
    Last Post: 07-23-2007, 11:14 PM
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •